What’s Vulnerable › Vulnerabilities
CVE-2019-1614: Cisco NX-OS Software NX-API Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-11 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the NX-API feature of Cisco NX-OS Software could allow an authenticated, remote attacker to execute arbitrary commands with root privileges. The vulnerability is due to incorrect input validation of user-supplied data by the NX-API subsystem. An attacker could exploit this vulnerability by sending malicious HTTP or HTTPS packets to the management interface of an affected system that has the NX-API feature enabled. A successful exploit could allow the attacker to perform a command-injection attack and execute arbitrary commands with root privileges. Note: NX-API is disabled by default. MDS 9000 Series Multilayer Switches are affected running software versions prior to 8.1(1b) and 8.2(3). Nexus 3000 Series Switches are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 3500 Platform Switches are affected running software versions prior to 7.0(3)I7(4). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected running software versions prior to 7.3(4)N1(1). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 7000 and 7700 Series Switches are affected running software versions prior to 7.3(3)D1(1) and 8.2(3).
Affected products
- Cisco NX-OS: from 8.2 before 8.3\(2\); from 7.3 before 8.1\(1b\); from 7.0\(3\)i5 before 7.0\(3\)i7\(4\); before 7.0\(3\)i4\(9\); from 7.0\(3\) before 7.0\(3\)i7\(4\); from 7.3 before 7.3\(4\)n1\(1\) — fixed in 7.0\(3\)i4\(9\), 7.0\(3\)i7\(4\), 7.3\(3\)d1\(1\), 7.3\(3\)i4\(9\), 7.3\(4\)n1\(1\), 8.1\(1b\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.0\(3\)i4\(9\), 7.0\(3\)i7\(4\), 7.3\(3\)d1\(1\), 7.3\(3\)i4\(9\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107339
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-NXAPI-cmdinj
- http://www.securityfocus.com/bid/107339
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-NXAPI-cmdinj
Get alerted when CVE-2019-1614 or the next vulnerability affects your stack