What’s Vulnerable › Vulnerabilities
CVE-2019-16143
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-327
Description
An issue was discovered in the blake2 crate before 0.8.1 for Rust. The BLAKE2b and BLAKE2s algorithms, when used with HMAC, produce incorrect results because the block sizes are half of the required sizes.
Affected products
- Blake2-Rust: before 0.8.1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: Blake2-Rust 0.8.1. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2019-0019.html
- https://rustsec.org/advisories/RUSTSEC-2019-0019.html
Get alerted when CVE-2019-16143 or the next vulnerability affects your stack