What’s Vulnerable › Vulnerabilities
CVE-2019-16144
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-908
Description
An issue was discovered in the generator crate before 0.6.18 for Rust. Uninitialized memory is used by Scope, done, and yield_ during API calls.
Affected products
- Generator-Rs Project Generator-Rs: before 0.6.18 — fixed in 0.6.18
How to fix
Upgrade to a fixed version: Generator-Rs Project Generator-Rs 0.6.18. Check the vendor advisory for mitigations.
References
- https://github.com/Xudong-Huang/generator-rs/issues/9
- https://rustsec.org/advisories/RUSTSEC-2019-0020.html
- https://github.com/Xudong-Huang/generator-rs/issues/9
- https://rustsec.org/advisories/RUSTSEC-2019-0020.html
Get alerted when CVE-2019-16144 or the next vulnerability affects your stack