What’s Vulnerable › Vulnerabilities
CVE-2019-16170
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-16 · updated 2026-06-17
Description
An issue was discovered in GitLab Enterprise Edition 11.x and 12.x before 12.0.9, 12.1.x before 12.1.9, and 12.2.x before 12.2.5. It has Incorrect Access Control.
Affected products
- GitLab: from 11.6.0 before 12.0.9; from 12.1.0 before 12.1.9; from 12.2.0 before 12.2.5 — fixed in 12.0.9, 12.1.9, 12.2.5
How to fix
Upgrade to a fixed version: GitLab 12.0.9, 12.1.9, 12.2.5. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/09/10/critical-security-release-gitlab-12-dot-2-dot-5-released/
- https://about.gitlab.com/2019/09/10/critical-security-release-gitlab-12-dot-2-dot-5-released/
Get alerted when CVE-2019-16170 or the next vulnerability affects your stack