What’s Vulnerable › Vulnerabilities
CVE-2019-16172
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
LimeSurvey before v3.17.14 allows stored XSS for escalating privileges from a low-privileged account to, for example, SuperAdmin. The attack uses a survey group in which the title contains JavaScript that is mishandled upon group deletion.
Affected products
- LimeSurvey: before 3.17.4 — fixed in 3.17.4
How to fix
Upgrade to a fixed version: LimeSurvey 3.17.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/154479/LimeSurvey-3.17.13-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2019/Sep/22
- https://github.com/LimeSurvey/LimeSurvey/commit/32d6a5224327b246ee3a2a08500544e4f80f9a9a
- https://seclists.org/bugtraq/2019/Sep/27
- https://www.limesurvey.org/limesurvey-updates/2188-limesurvey-3-17-14-build-190902-released
- http://packetstormsecurity.com/files/154479/LimeSurvey-3.17.13-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2019/Sep/22
- https://github.com/LimeSurvey/LimeSurvey/commit/32d6a5224327b246ee3a2a08500544e4f80f9a9a
- https://seclists.org/bugtraq/2019/Sep/27
- https://www.limesurvey.org/limesurvey-updates/2188-limesurvey-3-17-14-build-190902-released
Get alerted when CVE-2019-16172 or the next vulnerability affects your stack