What’s Vulnerable › Vulnerabilities
CVE-2019-16178
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability was found in Limesurvey before 3.17.14 that allows authenticated users with correct permissions to inject arbitrary web script or HTML via titles of admin box buttons on the home page.
Affected products
- LimeSurvey: before 3.17.14 — fixed in 3.17.14
How to fix
Upgrade to a fixed version: LimeSurvey 3.17.14. Check the vendor advisory for mitigations.
References
- https://github.com/LimeSurvey/LimeSurvey/commit/5870fd1037058bc4e43cccf893b576c72293371e#diff-d539f3f8185667ee48db78e1bf65a3b4R39
- https://www.limesurvey.org/limesurvey-updates/2188-limesurvey-3-17-14-build-190902-released
- https://github.com/LimeSurvey/LimeSurvey/commit/5870fd1037058bc4e43cccf893b576c72293371e#diff-d539f3f8185667ee48db78e1bf65a3b4R39
- https://www.limesurvey.org/limesurvey-updates/2188-limesurvey-3-17-14-build-190902-released
Get alerted when CVE-2019-16178 or the next vulnerability affects your stack