What’s Vulnerable › Vulnerabilities
CVE-2019-16204
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-05 · updated 2026-06-17
- Weakness: CWE-532
Description
Brocade Fabric OS Versions before v7.4.2f, v8.2.2a, v8.1.2j and v8.2.1d could expose external passwords, common secrets or authentication keys used between the switch and an external server.
Affected products
- Brocade Fabric OS: before 7.4.2f; from 8.1.2 before 8.1.2j; from 8.2.1 before 8.2.1d; from 8.2.2 before 8.2.2a — fixed in 7.4.2f, 8.1.2j, 8.2.1d, 8.2.2a
How to fix
Upgrade to a fixed version: Brocade Fabric OS 7.4.2f, 8.1.2j, 8.2.1d, 8.2.2a. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20200511-0007/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2020-905
- https://security.netapp.com/advisory/ntap-20200511-0007/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2020-905
Get alerted when CVE-2019-16204 or the next vulnerability affects your stack