What’s Vulnerable › Vulnerabilities
CVE-2019-16223
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-11 · updated 2026-06-17
- Weakness: CWE-79
Description
WordPress before 5.2.3 allows XSS in post previews by authenticated users.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- WordPress: before 5.2.3 — fixed in 5.2.3
How to fix
Upgrade to a fixed version: WordPress 5.2.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160745/WordPress-Core-5.2.2-Cross-Site-Scripting.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00023.html
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/09/wordpress-5-2-3-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9862
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- http://packetstormsecurity.com/files/160745/WordPress-Core-5.2.2-Cross-Site-Scripting.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00023.html
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/09/wordpress-5-2-3-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9862
Get alerted when CVE-2019-16223 or the next vulnerability affects your stack