What’s Vulnerable › Vulnerabilities
CVE-2019-1624: Cisco SD-WAN Solution Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-20 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the vManage web-based UI (Web UI) in the Cisco SD-WAN Solution could allow an authenticated, remote attacker to inject arbitrary commands that are executed with root privileges. The vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by authenticating to the device and submitting crafted input to the vManage Web UI. A successful exploit could allow the attacker to execute commands with root privileges.
Affected products
- Cisco Sd-Wan: before 18.4.0 — fixed in 18.4.0
How to fix
Upgrade to a fixed version: Cisco Sd-Wan 18.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108845
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190619-sdwan-cmdinj
- http://www.securityfocus.com/bid/108845
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190619-sdwan-cmdinj
Get alerted when CVE-2019-1624 or the next vulnerability affects your stack