What’s Vulnerable › Vulnerabilities
CVE-2019-16289
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The insert-php (aka Woody ad snippets) plugin before 2.2.8 for WordPress allows authenticated XSS via the winp_item parameter.
Affected products
- Webcraftic Woody Ad Snippets: before 2.2.8 — fixed in 2.2.8
How to fix
Upgrade to a fixed version: Webcraftic Woody Ad Snippets 2.2.8. Check the vendor advisory for mitigations.
References
- https://generaleg0x01.com/2019/09/13/xss-woody/
- https://wordpress.org/plugins/insert-php/#developers
- https://wpvulndb.com/vulnerabilities/9880
- https://generaleg0x01.com/2019/09/13/xss-woody/
- https://wordpress.org/plugins/insert-php/#developers
- https://wpvulndb.com/vulnerabilities/9880
Get alerted when CVE-2019-16289 or the next vulnerability affects your stack