What’s Vulnerable › Vulnerabilities
CVE-2019-16318
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-14 · updated 2026-06-17
- Weakness: CWE-434
Description
In Pimcore before 5.7.1, an attacker with limited privileges can bypass file-extension restrictions via a 256-character filename, as demonstrated by the failure of automatic renaming of .php to .php.txt for long filenames, a different vulnerability than CVE-2019-10867 and CVE-2019-16317.
Affected products
- pimcore/pimcore: before 5.7.1 — fixed in 5.7.1
How to fix
Upgrade to a fixed version: pimcore/pimcore 5.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/732f1647cc6e0a29b5b1f5d904b4d726b5e9455f
- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-451598
- https://github.com/pimcore/pimcore/commit/732f1647cc6e0a29b5b1f5d904b4d726b5e9455f
- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-451598
Get alerted when CVE-2019-16318 or the next vulnerability affects your stack