What’s Vulnerable › Vulnerabilities
CVE-2019-1634: Cisco Integrated Management Controller Command Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the Intelligent Platform Management Interface (IPMI) of Cisco Integrated Management Controller (IMC) could allow an authenticated, remote attacker to inject arbitrary commands that are executed with root privileges on the underlying operating system (OS). The vulnerability is due to insufficient input validation of user-supplied commands. An attacker who has administrator privileges and access to the network where the IPMI resides could exploit this vulnerability by submitting crafted input to the affected commands. A successful exploit could allow the attacker to gain root privileges on the affected device.
Affected products
- Cisco Integrated Management Controller: from 1.5.0.0 before 1.5\(9g\); from 2.0.0.0 before 2.0\(13o\); from 3.0.0.0 before 3.0\(4k\); from 4.0.0.0 before 4.0\(4b\); from 4.0.0.0 before 4.0\(2f\) — fixed in 1.5\(9g\), 2.0\(13o\), 3.0\(4k\), 4.0\(2f\), 4.0\(4b\)
- Cisco Unified Computing System (Managed): 4.0(1c)hs3
How to fix
Upgrade to a fixed version: Cisco Integrated Management Controller 1.5\(9g\), 2.0\(13o\), 3.0\(4k\), 4.0\(2f\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-imc-cmdinject-1634
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-imc-cmdinject-1634
Get alerted when CVE-2019-1634 or the next vulnerability affects your stack