What’s Vulnerable › Vulnerabilities
CVE-2019-16370
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-16 · updated 2026-06-17
- Weakness: CWE-327
Description
The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.
Affected products
- gradle: before 6.0 — fixed in 6.0
How to fix
Upgrade to a fixed version: gradle 6.0. Check the vendor advisory for mitigations.
References
- https://github.com/gradle/gradle/commit/425b2b7a50cd84106a77cdf1ab665c89c6b14d2f
- https://github.com/gradle/gradle/pull/10543
- https://github.com/gradle/gradle/commit/425b2b7a50cd84106a77cdf1ab665c89c6b14d2f
- https://github.com/gradle/gradle/pull/10543
Get alerted when CVE-2019-16370 or the next vulnerability affects your stack