What’s Vulnerable › Vulnerabilities
CVE-2019-16413
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-19 · updated 2026-06-17
- Weakness: CWE-835
Description
An issue was discovered in the Linux kernel before 5.0.4. The 9p filesystem did not protect i_size_write() properly, which causes an i_size_read() infinite loop and denial of service on SMP systems.
Affected products
- Linux kernel: before 5.0.4 — fixed in 5.0.4
How to fix
Upgrade to a fixed version: Linux kernel 5.0.4. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.4
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=5e3cc1ee1405a7eb3487ed24f786dec01b4cbe1f
- https://patchwork.kernel.org/patch/10753365/
- https://security.netapp.com/advisory/ntap-20191004-0001/
- https://support.f5.com/csp/article/K43239141?utm_source=f5support&%3Butm_medium=RSS
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.4
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=5e3cc1ee1405a7eb3487ed24f786dec01b4cbe1f
- https://patchwork.kernel.org/patch/10753365/
- https://security.netapp.com/advisory/ntap-20191004-0001/
- https://support.f5.com/csp/article/K43239141?utm_source=f5support&%3Butm_medium=RSS
Get alerted when CVE-2019-16413 or the next vulnerability affects your stack