What’s Vulnerable › Vulnerabilities
CVE-2019-16451
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 34.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-19 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Acrobat and Reader versions , 2019.021.20056 and earlier, 2017.011.30152 and earlier, 2017.011.30155 and earlier version, 2017.011.30152 and earlier, and 2015.006.30505 and earlier have a heap overflow vulnerability. Successful exploitation could lead to arbitrary code execution .
Affected products
- Adobe Acrobat DC: from 15.006.30060 before 15.006.30508; from 15.008.20082 before 19.021.20058; from 17.011.30059 before 17.011.30156 — fixed in 15.006.30508, 17.011.30156, 19.021.20058
- Adobe Acrobat Reader: from 15.006.30060 before 15.006.30508; from 15.008.20082 before 19.021.20058; from 17.011.30059 before 17.011.30156 — fixed in 15.006.30508, 17.011.30156, 19.021.20058
How to fix
Upgrade to a fixed version: Adobe Acrobat DC 15.006.30508, 17.011.30156, 19.021.20058; Adobe Acrobat Reader 15.006.30508, 17.011.30156, 19.021.20058. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb19-55.html
- https://www.zerodayinitiative.com/advisories/ZDI-20-145/
- https://helpx.adobe.com/security/products/acrobat/apsb19-55.html
- https://www.zerodayinitiative.com/advisories/ZDI-20-145/
Get alerted when CVE-2019-16451 or the next vulnerability affects your stack