What’s Vulnerable › Vulnerabilities
CVE-2019-1646: Privilege Escalation Vulnerability in Cisco SD-WAN Solution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-24 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the local CLI of the Cisco SD-WAN Solution could allow an authenticated, local attacker to escalate privileges and modify device configuration files. The vulnerability exists because user input is not properly sanitized for certain commands at the CLI. An attacker could exploit this vulnerability by sending crafted commands to the CLI of an affected device. A successful exploit could allow the attacker to establish an interactive session with elevated privileges. The attacker could then use the elevated privileges to further compromise the device or obtain additional configuration data from the device.
Affected products
- Cisco Sd-Wan: before 18.4.0 — fixed in 18.4.0
- Cisco Vbond Orchestrator: all versions
- Cisco Vedge 1000 Firmware: all versions
- Cisco Vedge 100 Firmware: all versions
- Cisco Vedge 2000 Firmware: all versions
- Cisco Vedge 5000 Firmware: all versions
- Cisco Vmanage Network Management: all versions
- Cisco Vsmart Controller: all versions
How to fix
Upgrade to a fixed version: Cisco Sd-Wan 18.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106723
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190123-sdwan-escal
- http://www.securityfocus.com/bid/106723
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190123-sdwan-escal
Get alerted when CVE-2019-1646 or the next vulnerability affects your stack