What’s Vulnerable › Vulnerabilities
CVE-2019-1649: Cisco Secure Boot Hardware Tampering Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-13 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability in the logic that handles access control to one of the hardware components in Cisco's proprietary Secure Boot implementation could allow an authenticated, local attacker to write a modified firmware image to the component. This vulnerability affects multiple Cisco products that support hardware-based Secure Boot functionality. The vulnerability is due to an improper check on the area of code that manages on-premise updates to a Field Programmable Gate Array (FPGA) part of the Secure Boot hardware implementation. An attacker with elevated privileges and access to the underlying operating system that is running on the affected device could exploit this vulnerability by writing a modified firmware image to the FPGA. A successful exploit could either cause the device to become unusable (and require a hardware replacement) or allow tampering with the Secure Boot verification process, which under some circumstances may allow the attacker to install and boot a malicious software image. An attacker will need to fulfill all the following conditions to attempt to exploit this vulnerability: Have privileged administrative access to the device. Be able to access the underlying operating system running on the device; this can be achieved either by using a supported, documented mechanism or by exploiting another vulnerability that would provide an attacker with such access. Develop or have access to a platform-specific exploit. An attacker attempting to exploit this vulnerability across multiple affected platforms would need to research each one of those platforms and then develop a platform-specific exploit. Although the research process could be reused across different platforms, an exploit developed for a given hardware platform is unlikely to work on a different hardware platform.
Affected products
- Cisco 15454-M-Wse-K9 Firmware: before 11.1 — fixed in 11.1
- Cisco Analog Voice Network Interface Modules Firmware: all versions
- Cisco Asa 5500 Firmware: before 1.1.15 — fixed in 1.1.15
- Cisco Asr 1000 Series Firmware: all versions
- Cisco Asr 1001 Firmware: 16.0.0
- Cisco Catalyst 9800-40 Wireless Controller Firmware: all versions
- Cisco Catalyst 9800-80 Wireless Controller Firmware: all versions
- Cisco Encs 5100 Firmware: all versions
- Cisco Encs 5400 Firmware: all versions
- Cisco Firepower 2100 Firmware: before 2.6.1.134 — fixed in 2.6.1.134
- Cisco Firepower 4000 Firmware: before 1.0.18 — fixed in 1.0.18
- Cisco Firepower 9000 Firmware: before 1.0.18 — fixed in 1.0.18
- Cisco Ic3000-K9 Firmware: before 1.0.2 — fixed in 1.0.2
- Cisco Industrial Security Appliances 3000 Firmware: before 1.0.05 — fixed in 1.0.05
- Cisco Integrated Services Router 4200 Firmware: before 1.1 — fixed in 1.1
- Cisco Integrated Services Router 4300 Firmware: before 1.1 — fixed in 1.1
- Cisco Integrated Services Router 4400 Firmware: before 1.1 — fixed in 1.1
- Cisco Integrated Services Router T1/E1 Voice And Wan Network Interface Modules Firmware: all versions
- Cisco IOS: before 15.6\(3\)m7; from 15.7 through 15.7\(3\)m5; from 15.8 before 15.8\(3\)m3; from 15.9 before 15.9\(3\)m; before 15.6\(3\)m6b; from 15.7 through 15.7\(3\)m4b — fixed in 15.6\(3\)m6b, 15.6\(3\)m7, 15.8\(3\)m2a, 15.8\(3\)m3, 15.9\(3\)m
- Cisco IOS XE: before 16.12.1; before 16.3.9; from 16.4.0 before 16.6.7; from 16.7.0 before 16.9.4; from 16.10.0 before 16.12.1; before 16.2.1 — fixed in 15.5\(1\)sy4, 16.12.1, 16.2.1, 16.3.9, 16.6.7, 16.9.4
- Cisco IOS XR Software: 7.0.1, 7.1.1
- Cisco Ncs2K-Mr-Mxp-K9 Firmware: before 11.1 — fixed in 11.1
- Cisco NX-OS: before 8.4.1; before 9.3\(2\) — fixed in 8.4.1, 9.3\(2\)
- Cisco Ons 15454 Mstp Firmware: before 11.1 — fixed in 11.1
- Cisco Sm-X-1T3/E3 Firmware: all versions
- Cisco Supervisor A+ Firmware: all versions
- Cisco Supervisor B+ Firmware: all versions
How to fix
Upgrade to a fixed version: Cisco 15454-M-Wse-K9 Firmware 11.1; Cisco Asa 5500 Firmware 1.1.15; Cisco Firepower 2100 Firmware 2.6.1.134; Cisco Firepower 4000 Firmware 1.0.18; Cisco Firepower 9000 Firmware 1.0.18; Cisco Ic3000-K9 Firmware 1.0.2; Cisco Industrial Security Appliances 3000 Firmware 1.0.05; Cisco Integrated Services Router 4200 Firmware 1.1; Cisco Integrated Services Router 4300 Firmware 1.1; Cisco Integrated Services Router 4400 Firmware 1.1; Cisco IOS 15.6\(3\)m6b, 15.6\(3\)m7, 15.8\(3\)m2a, 15.8\(3\)m3; Cisco IOS XE 15.5\(1\)sy4, 16.12.1, 16.2.1, 16.3.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108350
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190513-secureboot
- https://www.kb.cert.org/vuls/id/400865
- https://www.us-cert.gov/ics/advisories/icsa-20-072-03
- http://www.securityfocus.com/bid/108350
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190513-secureboot
- https://www.kb.cert.org/vuls/id/400865
- https://www.us-cert.gov/ics/advisories/icsa-20-072-03
Get alerted when CVE-2019-1649 or the next vulnerability affects your stack