What’s Vulnerable › Vulnerabilities
CVE-2019-16520
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The all-in-one-seo-pack plugin before 3.2.7 for WordPress (aka All in One SEO Pack) is susceptible to Stored XSS due to improper encoding of the SEO-specific description for posts provided by the plugin via unsafe placeholder replacement.
Affected products
- Semperplugins All In One Seo Pack: before 3.2.7 — fixed in 3.2.7
How to fix
Upgrade to a fixed version: Semperplugins All In One Seo Pack 3.2.7. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/10/16/5
- https://github.com/sbaresearch/advisories/tree/public/2019/SBA-ADV-20190913-04_WordPress_Plugin_All_in_One_SEO_Pack
- https://github.com/semperfiwebdesign/all-in-one-seo-pack/issues/2888
- https://semperplugins.com/all-in-one-seo-pack-changelog/
- https://wordpress.org/plugins/all-in-one-seo-pack/#developers
- https://wpvulndb.com/vulnerabilities/9915
- http://www.openwall.com/lists/oss-security/2019/10/16/5
- https://github.com/sbaresearch/advisories/tree/public/2019/SBA-ADV-20190913-04_WordPress_Plugin_All_in_One_SEO_Pack
- https://github.com/semperfiwebdesign/all-in-one-seo-pack/issues/2888
- https://semperplugins.com/all-in-one-seo-pack-changelog/
- https://wordpress.org/plugins/all-in-one-seo-pack/#developers
- https://wpvulndb.com/vulnerabilities/9915
Get alerted when CVE-2019-16520 or the next vulnerability affects your stack