What’s Vulnerable › Vulnerabilities
CVE-2019-16524
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The easy-fancybox plugin before 1.8.18 for WordPress (aka Easy FancyBox) is susceptible to Stored XSS in the Settings Menu inc/class-easyfancybox.php due to improper encoding of arbitrarily submitted settings parameters. This occurs because there is no inline styles output filter.
Affected products
- Status301 Easy Fancybox: before 1.8.18 — fixed in 1.8.18
How to fix
Upgrade to a fixed version: Status301 Easy Fancybox 1.8.18. Check the vendor advisory for mitigations.
References
- https://github.com/sbaresearch/advisories/tree/public/2019/SBA-ADV-20190911-01_Easy_FancyBox_WP_Plugin_Stored_XSS
- https://wordpress.org/plugins/easy-fancybox/#developers
- https://wpvulndb.com/vulnerabilities/9891
- https://github.com/sbaresearch/advisories/tree/public/2019/SBA-ADV-20190911-01_Easy_FancyBox_WP_Plugin_Stored_XSS
- https://wordpress.org/plugins/easy-fancybox/#developers
- https://wpvulndb.com/vulnerabilities/9891
Get alerted when CVE-2019-16524 or the next vulnerability affects your stack