What’s Vulnerable › Vulnerabilities
CVE-2019-16525
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
An XSS issue was discovered in the checklist plugin before 1.1.9 for WordPress. The fill parameter is not correctly filtered in the checklist-icon.php file, and it is possible to inject JavaScript code.
Affected products
- Checklist: before 1.1.9 — fixed in 1.1.9
How to fix
Upgrade to a fixed version: Checklist 1.1.9. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/154436/WordPress-Checklist-1.1.5-Cross-Site-Scripting.html
- https://plugins.trac.wordpress.org/changeset/2155029/
- https://wordpress.org/plugins/checklist/#developers
- https://wpvulndb.com/vulnerabilities/9877
- https://packetstormsecurity.com/files/154436/WordPress-Checklist-1.1.5-Cross-Site-Scripting.html
- https://plugins.trac.wordpress.org/changeset/2155029/
- https://wordpress.org/plugins/checklist/#developers
- https://wpvulndb.com/vulnerabilities/9877
Get alerted when CVE-2019-16525 or the next vulnerability affects your stack