What’s Vulnerable › Vulnerabilities
CVE-2019-16531
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-20 · updated 2026-06-17
- Weakness: CWE-352
Description
LayerBB before 1.1.4 has multiple CSRF issues, as demonstrated by changing the System Settings via admin/general.php.
Affected products
- LayerBB: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: LayerBB 1.1.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/154549/LayerBB-1.1.3-Cross-Site-Request-Forgery.html
- https://github.com/0xB9/LayerBB-1.1.3-CSRF/blob/master/README.md
- https://github.com/AndyRixon/LayerBB/compare/1.1.3...1.1.4
- https://github.com/AndyRixon/LayerBB/pull/40
- http://packetstormsecurity.com/files/154549/LayerBB-1.1.3-Cross-Site-Request-Forgery.html
- https://github.com/0xB9/LayerBB-1.1.3-CSRF/blob/master/README.md
- https://github.com/AndyRixon/LayerBB/compare/1.1.3...1.1.4
- https://github.com/AndyRixon/LayerBB/pull/40
Get alerted when CVE-2019-16531 or the next vulnerability affects your stack