What’s Vulnerable › Vulnerabilities
CVE-2019-16547
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-21 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing permission checks in various API endpoints in Jenkins Google Compute Engine Plugin 4.1.1 and earlier allow attackers with Overall/Read permission to obtain limited information about the plugin configuration and environment.
Affected products
- Jenkins project Jenkins Google Compute Engine Plugin: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Google Compute Engine Plugin 4.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/11/21/1
- https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1585
- http://www.openwall.com/lists/oss-security/2019/11/21/1
- https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1585
Get alerted when CVE-2019-16547 or the next vulnerability affects your stack