What’s Vulnerable › Vulnerabilities
CVE-2019-1657: Cisco AMP Threat Grid API Key Information Disclosure Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-24 · updated 2026-06-17
- Weakness: CWE-200
Description
A vulnerability in Cisco AMP Threat Grid could allow an authenticated, remote attacker to access sensitive information. The vulnerability is due to unsafe creation of API keys. An attacker could exploit this vulnerability by using insecure credentials to gain unauthorized access to the affected device. An exploit could allow the attacker to gain unauthorized access to information by using the API key credentials.
Affected products
- Cisco Amp Threat Grid Appliance: before 2.5 — fixed in 2.5
- Cisco Amp Threat Grid Cloud: before 3.5.68 — fixed in 3.5.68
How to fix
Upgrade to a fixed version: Cisco Amp Threat Grid Appliance 2.5; Cisco Amp Threat Grid Cloud 3.5.68. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106711
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190123-threat-grid
- http://www.securityfocus.com/bid/106711
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190123-threat-grid
Get alerted when CVE-2019-1657 or the next vulnerability affects your stack