What’s Vulnerable › Vulnerabilities
CVE-2019-16680
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-21 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in GNOME file-roller before 3.29.91. It allows a single ./../ path traversal via a filename contained in a TAR archive, possibly overwriting a file during extraction.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Debian Linux: 8.0, 9.0
- GNOME File-Roller: before 3.29.91 — fixed in 3.29.91
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: GNOME File-Roller 3.29.91. Check the vendor advisory for mitigations.
References
- https://bugzilla.gnome.org/show_bug.cgi?id=794337
- https://gitlab.gnome.org/GNOME/file-roller/commit/57268e51e59b61c9e3125eb0f65551c7084297e2
- https://gitlab.gnome.org/GNOME/file-roller/commit/e8fb3e24dae711e4fb0d6777e0016cdda8787bc1
- https://lists.debian.org/debian-lts-announce/2019/09/msg00032.html
- https://seclists.org/bugtraq/2019/Sep/57
- https://usn.ubuntu.com/4139-1/
- https://www.debian.org/security/2019/dsa-4537
- https://bugzilla.redhat.com/show_bug.cgi?id=1767594
- https://bugzilla.gnome.org/show_bug.cgi?id=794337
- https://gitlab.gnome.org/GNOME/file-roller/commit/57268e51e59b61c9e3125eb0f65551c7084297e2
- https://gitlab.gnome.org/GNOME/file-roller/commit/e8fb3e24dae711e4fb0d6777e0016cdda8787bc1
- https://lists.debian.org/debian-lts-announce/2019/09/msg00032.html
Get alerted when CVE-2019-16680 or the next vulnerability affects your stack