What’s Vulnerable › Vulnerabilities
CVE-2019-16701
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-25 · updated 2026-06-17
- Weakness: CWE-78
Description
pfSense through 2.3.4 through 2.4.4-p3 allows Remote Code Injection via a methodCall XML document with a pfsense.exec_php call containing shell metacharacters in a parameter value.
Affected products
- Netgate pfSense: from 2.3.4 before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.4-p3 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/154587/pfSense-2.3.4-2.4.4-p3-Remote-Code-Injection.html
- https://github.com/pfsense/pfsense/commits/master
- https://hackernews.blog/pfsense-2-3-4-2-4-4-p3-remote-code-injection/#more
- http://packetstormsecurity.com/files/154587/pfSense-2.3.4-2.4.4-p3-Remote-Code-Injection.html
- https://github.com/pfsense/pfsense/commits/master
- https://hackernews.blog/pfsense-2-3-4-2-4-4-p3-remote-code-injection/#more
Get alerted when CVE-2019-16701 or the next vulnerability affects your stack