What’s Vulnerable › Vulnerabilities
CVE-2019-16718
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-23 · updated 2026-06-17
- Weakness: CWE-78
Description
In radare2 before 3.9.0, a command injection vulnerability exists in bin_symbols() in libr/core/cbin.c. By using a crafted executable file, it's possible to execute arbitrary shell commands with the permissions of the victim. This vulnerability is due to an insufficient fix for CVE-2019-14745 and improper handling of symbol names embedded in executables.
Affected products
- radareorg/radare2: before 3.9.0 — fixed in 3.9.0
How to fix
Upgrade to a fixed version: radareorg/radare2 3.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/radareorg/radare2/commit/5411543a310a470b1257fb93273cdd6e8dfcb3af
- https://github.com/radareorg/radare2/commit/dd739f5a45b3af3d1f65f00fe19af1dbfec7aea7
- https://github.com/radareorg/radare2/compare/3.8.0...3.9.0
- https://github.com/radareorg/radare2/commit/5411543a310a470b1257fb93273cdd6e8dfcb3af
- https://github.com/radareorg/radare2/commit/dd739f5a45b3af3d1f65f00fe19af1dbfec7aea7
- https://github.com/radareorg/radare2/compare/3.8.0...3.9.0
Get alerted when CVE-2019-16718 or the next vulnerability affects your stack