What’s Vulnerable › Vulnerabilities
CVE-2019-16728
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-24 · updated 2026-06-17
- Weakness: CWE-79
Description
DOMPurify before 2.0.1 allows XSS because of innerHTML mutation XSS (mXSS) for an SVG element or a MATH element, as demonstrated by Chrome and Safari.
Affected products
- cure53 DOMPurify: before 2.0.1 — fixed in 2.0.1
- Debian Linux: 9.0
How to fix
Upgrade to a fixed version: cure53 DOMPurify 2.0.1. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2020/10/msg00029.html
- https://research.securitum.com/dompurify-bypass-using-mxss/
- https://lists.debian.org/debian-lts-announce/2020/10/msg00029.html
- https://research.securitum.com/dompurify-bypass-using-mxss/
Get alerted when CVE-2019-16728 or the next vulnerability affects your stack