What’s Vulnerable › Vulnerabilities
CVE-2019-16746
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-24 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in net/wireless/nl80211.c in the Linux kernel through 5.2.17. It does not check the length of variable elements in a beacon head, leading to a buffer overflow.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Debian Linux: 8.0
- Fedoraproject Fedora: 30
- Linux kernel: from 2.6.25 before 3.16.79; from 3.17 before 4.4.197; from 4.5 before 4.9.197; from 4.10 before 4.14.149; from 4.15 before 4.19.79; from 4.20 before 5.3.6 — fixed in 3.16.79, 4.14.149, 4.19.79, 4.4.197, 4.9.197, 5.3.6
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Linux kernel 3.16.79, 4.14.149, 4.19.79, 4.4.197. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00009.html
- http://packetstormsecurity.com/files/155212/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
- https://lists.debian.org/debian-lts-announce/2020/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TASE2ESEZAER6DTZH3DJ4K2JNO46TVL7/
- https://marc.info/?l=linux-wireless&m=156901391225058&w=2
- https://seclists.org/bugtraq/2019/Nov/11
- https://security.netapp.com/advisory/ntap-20191031-0005/
- https://usn.ubuntu.com/4183-1/
- https://usn.ubuntu.com/4186-1/
- https://usn.ubuntu.com/4209-1/
Get alerted when CVE-2019-16746 or the next vulnerability affects your stack