What’s Vulnerable › Vulnerabilities
CVE-2019-16762: Validator parsing discrepancy due to string encoding in NPM slpjs
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-15 · updated 2026-06-17
- Weakness: CWE-20
Description
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
Affected products
- simpleledger slpjs: before 0.21.4 — fixed in 0.21.4
How to fix
Upgrade to a fixed version: simpleledger slpjs 0.21.4. Check the vendor advisory for mitigations.
References
- https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701
- https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr
- https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701
- https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr
Get alerted when CVE-2019-16762 or the next vulnerability affects your stack