What’s Vulnerable › Vulnerabilities
CVE-2019-16764: PowAssent is susceptible to denial of service attacks
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-25 · updated 2026-06-17
- Weakness: CWE-400
Description
The use of `String.to_atom/1` in PowAssent is susceptible to denial of service attacks. In `PowAssent.Phoenix.AuthorizationController` a value is fetched from the user provided params, and `String.to_atom/1` is used to convert the binary value to an atom so it can be used to fetch the provider configuration value. This is unsafe as it is user provided data, and can be used to fill up the whole atom table of ~1M which will cause the app to crash.
Affected products
- pow-auth pow_assent: before 0.4.4 — fixed in 0.4.4
How to fix
Upgrade to a fixed version: pow-auth pow_assent 0.4.4. Check the vendor advisory for mitigations.
References
- http://erlang.org/doc/efficiency_guide/commoncaveats.html#list_to_atom-1
- https://github.com/pow-auth/pow_assent/commit/026105eeecc0e3c2f807e7109e745ea93c0fd9cf
- https://github.com/pow-auth/pow_assent/security/advisories/GHSA-368c-xvrv-x986
- https://hex.pm/packages/pow_assent
- http://erlang.org/doc/efficiency_guide/commoncaveats.html#list_to_atom-1
- https://github.com/pow-auth/pow_assent/commit/026105eeecc0e3c2f807e7109e745ea93c0fd9cf
- https://github.com/pow-auth/pow_assent/security/advisories/GHSA-368c-xvrv-x986
- https://hex.pm/packages/pow_assent
Get alerted when CVE-2019-16764 or the next vulnerability affects your stack