What’s Vulnerable › Vulnerabilities
CVE-2019-16769: Affected versions of serialize-javascript are vulnerable to Cross-site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The serialize-javascript npm package before version 2.1.1 is vulnerable to Cross-site Scripting (XSS). It does not properly mitigate against unsafe characters in serialized regular expressions. This vulnerability is not affected on Node.js environment since Node.js's implementation of RegExp.prototype.toString() backslash-escapes all forward slashes in regular expressions. If serialized data of regular expression objects are used in an environment other than Node.js, it is affected by this vulnerability.
Affected products
- serialize-javascript: before 2.1.1 — fixed in 2.1.1
- Npm Serialize-Javascript: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: serialize-javascript 2.1.1; Npm Serialize-Javascript 2.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/yahoo/serialize-javascript/security/advisories/GHSA-h9rv-jmmf-4pgx
- https://github.com/yahoo/serialize-javascript/security/advisories/GHSA-h9rv-jmmf-4pgx
Get alerted when CVE-2019-16769 or the next vulnerability affects your stack