What’s Vulnerable › Vulnerabilities
CVE-2019-16772: regular expressions Cross-Site Scripting (XSS) vulnerability in serialize-to-js
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The serialize-to-js NPM package before version 3.0.1 is vulnerable to Cross-site Scripting (XSS). It does not properly mitigate against unsafe characters in serialized regular expressions. This vulnerability is not affected on Node.js environment since Node.js's implementation of RegExp.prototype.toString() backslash-escapes all forward slashes in regular expressions. If serialized data of regular expression objects are used in an environment other than Node.js, it is affected by this vulnerability.
Affected products
- commenthol serialize-to-js: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: commenthol serialize-to-js 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/commenthol/serialize-to-js/commit/181d7d583ae5293cd47cc99b14ad13352875f3e3
- https://github.com/commenthol/serialize-to-js/security/advisories/GHSA-3fjq-93xj-3f3f
- https://github.com/commenthol/serialize-to-js/commit/181d7d583ae5293cd47cc99b14ad13352875f3e3
- https://github.com/commenthol/serialize-to-js/security/advisories/GHSA-3fjq-93xj-3f3f
Get alerted when CVE-2019-16772 or the next vulnerability affects your stack