What’s Vulnerable › Vulnerabilities
CVE-2019-16774: Object injection in cookie driver
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-12 · updated 2026-06-17
- Weakness: CWE-94
Description
In phpfastcache before 5.1.3, there is a possible object injection vulnerability in cookie driver.
Affected products
- PHPSocialNetwork phpfastcache: before 5.0.13 — fixed in 5.0.13
How to fix
Upgrade to a fixed version: PHPSocialNetwork phpfastcache 5.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/PHPSocialNetwork/phpfastcache/commit/c4527205cb7a402b595790c74310791f5b04a1a4
- https://github.com/PHPSocialNetwork/phpfastcache/releases/tag/5.0.13
- https://github.com/PHPSocialNetwork/phpfastcache/security/advisories/GHSA-484f-743f-6jx2
- https://github.com/PHPSocialNetwork/phpfastcache/commit/c4527205cb7a402b595790c74310791f5b04a1a4
- https://github.com/PHPSocialNetwork/phpfastcache/releases/tag/5.0.13
- https://github.com/PHPSocialNetwork/phpfastcache/security/advisories/GHSA-484f-743f-6jx2
Get alerted when CVE-2019-16774 or the next vulnerability affects your stack