What’s Vulnerable › Vulnerabilities
CVE-2019-16777: Arbitrary File Overwrite in npm CLI
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.
Affected products
- Fedoraproject Fedora: 31
- Npmjs Npm: before 6.13.4 — fixed in 6.13.4
- openSUSE Leap: 15.1
- Oracle Corporation GraalVM Enterprise Edition: 19.3.0.2
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Eus: 8.1
How to fix
Upgrade to a fixed version: Npmjs Npm 6.13.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00027.html
- https://access.redhat.com/errata/RHEA-2020:0330
- https://access.redhat.com/errata/RHSA-2020:0573
- https://access.redhat.com/errata/RHSA-2020:0579
- https://access.redhat.com/errata/RHSA-2020:0597
- https://access.redhat.com/errata/RHSA-2020:0602
- https://blog.npmjs.org/post/189618601100/binary-planting-with-the-npm-cli
- https://github.com/npm/cli/security/advisories/GHSA-4328-8hgf-7wjr
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z36UKPO5F3PQ3Q2POMF5LEKXWAH5RUFP/
- https://security.gentoo.org/glsa/202003-48
- https://www.oracle.com/security-alerts/cpujan2020.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00027.html
Get alerted when CVE-2019-16777 or the next vulnerability affects your stack