What’s Vulnerable › Vulnerabilities
CVE-2019-16779: In RubyGem excon, interrupted Persistent Connections May Leak Response Data
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-16 · updated 2026-07-28
- Weakness: CWE-664
Description
In RubyGem excon before 0.71.0, there was a race condition around persistent connections, where a connection which is interrupted (such as by a timeout) would leave data on the socket. Subsequent requests would then read this data, returning content from the previous response. The race condition window appears to be short, and it would be difficult to purposefully exploit this.
Affected products
- Debian Linux: 8.0
- excon: before 0.71.0 — fixed in 0.71.0
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
- Rubygems Excon: before 0.71.0; 0.0.1, 0.0.10, 0.0.11, 0.0.12, 0.0.13, 0.0.14 (+201) — fixed in 0.71.0
How to fix
Upgrade to a fixed version: excon 0.71.0; Rubygems Excon 0.71.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00062.html
- https://github.com/excon/excon/commit/ccb57d7a422f020dc74f1de4e8fb505ab46d8a29
- https://github.com/excon/excon/security/advisories/GHSA-q58g-455p-8vw9
- https://lists.debian.org/debian-lts-announce/2020/01/msg00015.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00062.html
- https://github.com/excon/excon/commit/ccb57d7a422f020dc74f1de4e8fb505ab46d8a29
- https://github.com/excon/excon/security/advisories/GHSA-q58g-455p-8vw9
- https://lists.debian.org/debian-lts-announce/2020/01/msg00015.html
Get alerted when CVE-2019-16779 or the next vulnerability affects your stack