What’s Vulnerable › Vulnerabilities
CVE-2019-16780: Stored cross-site scripting (XSS) in WordPress block editor
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: from 3.7 (excl.) before 5.3.1; 3.7 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: WordPress 5.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/commit/505dd6a20b6fc3d06130018c1caeff764248c29e
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-x3wp-h3qx-9w94
- https://hackerone.com/reports/738644
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9976
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://github.com/WordPress/wordpress-develop/commit/505dd6a20b6fc3d06130018c1caeff764248c29e
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-x3wp-h3qx-9w94
- https://hackerone.com/reports/738644
- https://seclists.org/bugtraq/2020/Jan/8
Get alerted when CVE-2019-16780 or the next vulnerability affects your stack