What’s Vulnerable › Vulnerabilities
CVE-2019-16781: Stored cross-site scripting (XSS) in WordPress block editor
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: WordPress 5.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v
- https://hackerone.com/reports/731301
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9976
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v
- https://hackerone.com/reports/731301
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9976
Get alerted when CVE-2019-16781 or the next vulnerability affects your stack