What’s Vulnerable › Vulnerabilities
CVE-2019-1679: Cisco TelePresence Conductor, Cisco Expressway Series, and Cisco TelePresence Video Communication Server REST API Server-Side Request Forgery Vulnerability
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-07 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability in the web interface of Cisco TelePresence Conductor, Cisco Expressway Series, and Cisco TelePresence Video Communication Server (VCS) Software could allow an authenticated, remote attacker to trigger an HTTP request from an affected server to an arbitrary host. This type of attack is commonly referred to as server-side request forgery (SSRF). The vulnerability is due to insufficient access controls for the REST API of Cisco Expressway Series and Cisco TelePresence VCS. An attacker could exploit this vulnerability by submitting a crafted HTTP request to the affected server. Versions prior to XC4.3.4 are affected.
Affected products
- Cisco Telepresence Conductor: before xc4.3.4 — fixed in xc4.3.4
- Cisco TelePresence Video Communication Server (VCS) Expressway: before x12.5 — fixed in x12.5
How to fix
Upgrade to a fixed version: Cisco Telepresence Conductor xc4.3.4; Cisco TelePresence Video Communication Server (VCS) Expressway x12.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106940
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190206-rest-api-ssrf
- http://www.securityfocus.com/bid/106940
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190206-rest-api-ssrf
Get alerted when CVE-2019-1679 or the next vulnerability affects your stack