What’s Vulnerable › Vulnerabilities
CVE-2019-16791: downgrade of effective Strict Transport Security (STS) policy in postfix-mta-sts-resolver
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-22 · updated 2026-06-17
- Weakness: CWE-757
Description
In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.
Affected products
- Snawoot postfix-mta-sts-resolver: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: Snawoot postfix-mta-sts-resolver 0.5.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b
- https://github.com/Snawoot/postfix-mta-sts-resolver/security/advisories/GHSA-h92m-42h4-82f6
- https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b
- https://github.com/Snawoot/postfix-mta-sts-resolver/security/advisories/GHSA-h92m-42h4-82f6
Get alerted when CVE-2019-16791 or the next vulnerability affects your stack