What’s Vulnerable › Vulnerabilities
CVE-2019-1682: Cisco Application Policy Infrastructure Controller Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-03 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the FUSE filesystem functionality for Cisco Application Policy Infrastructure Controller (APIC) software could allow an authenticated, local attacker to escalate privileges to root on an affected device. The vulnerability is due to insufficient input validation for certain command strings issued on the CLI of the affected device. An attacker with write permissions for files within a readable folder on the device could alter certain definitions in the affected file. A successful exploit could allow an attacker to cause the underlying FUSE driver to execute said crafted commands, elevating the attacker's privileges to root on an affected device.
Affected products
- Cisco Application Policy Infrastructure Controller (APIC): before 4.1\(1i\) — fixed in 4.1\(1i\)
How to fix
Upgrade to a fixed version: Cisco Application Policy Infrastructure Controller (APIC) 4.1\(1i\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-apic-priv-escalation
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-apic-priv-escalation
Get alerted when CVE-2019-1682 or the next vulnerability affects your stack