What’s Vulnerable › Vulnerabilities
CVE-2019-1687: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software TCP Proxy Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-03 · updated 2026-08-11
- Weakness: CWE-20
Description
A vulnerability in the TCP proxy functionality for Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to restart unexpectedly, resulting in a denial of service (DoS) condition. The vulnerability is due to an error in TCP-based packet inspection, which could cause the TCP packet to have an invalid Layer 2 (L2)-formatted header. An attacker could exploit this vulnerability by sending a crafted TCP packet sequence to the targeted device. A successful exploit could allow the attacker to cause a DoS condition.
Affected products
- Cisco ASA Software: before 9.4.4.34; from 9.5 before 9.6.4.25; from 9.7 before 9.8.4; from 9.9 before 9.9.2.50; from 9.10 before 9.10.1.17 — fixed in 9.10.1.17, 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50
- Cisco Firepower Threat Defense Software: from 6.0.0 before 6.2.3.12; from 6.3.0 before 6.3.0.3 — fixed in 6.2.3.12, 6.3.0.3
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.10.1.17, 9.4.4.34, 9.6.4.25, 9.8.4; Cisco Firepower Threat Defense Software 6.2.3.12, 6.3.0.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108176
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-asa-ftdtcp-dos
- http://www.securityfocus.com/bid/108176
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-asa-ftdtcp-dos
Get alerted when CVE-2019-1687 or the next vulnerability affects your stack