What’s Vulnerable › Vulnerabilities
CVE-2019-16882
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-25 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the string-interner crate before 0.7.1 for Rust. It allows attackers to read from memory locations associated with dangling pointers, because of a cloning flaw.
Affected products
- String-Interner Project String-Interner: before 0.7.1 — fixed in 0.7.1
How to fix
Upgrade to a fixed version: String-Interner Project String-Interner 0.7.1. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2019-0023.html
- https://rustsec.org/advisories/RUSTSEC-2019-0023.html
Get alerted when CVE-2019-16882 or the next vulnerability affects your stack