What’s Vulnerable › Vulnerabilities
CVE-2019-16914
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-79
Description
An XSS issue was discovered in pfSense through 2.4.4-p3. In services_captiveportal_mac.php, the username and delmac parameters are displayed without sanitization.
Affected products
- Netgate pfSense: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.4-p3 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/pfsense/commit/d31362b69d5d52dc196dc72f66e830cd1e6e9a4f
- https://redmine.pfsense.org/issues/9609
- https://www.seebug.org/vuldb/ssvid-98023
- https://github.com/pfsense/pfsense/commit/d31362b69d5d52dc196dc72f66e830cd1e6e9a4f
- https://redmine.pfsense.org/issues/9609
- https://www.seebug.org/vuldb/ssvid-98023
Get alerted when CVE-2019-16914 or the next vulnerability affects your stack