What’s Vulnerable › Vulnerabilities
CVE-2019-16915
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-26 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in pfSense through 2.4.4-p3. widgets/widgets/picture.widget.php uses the widgetkey parameter directly without sanitization (e.g., a basename call) for a pathname to file_get_contents or file_put_contents.
Affected products
- Netgate pfSense: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.4-p3 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/pfsense/commit/2c544ac61ce98f716d50b8e5961d7dfba66804b5
- https://redmine.pfsense.org/issues/9610
- https://www.seebug.org/vuldb/ssvid-98024
- https://github.com/pfsense/pfsense/commit/2c544ac61ce98f716d50b8e5961d7dfba66804b5
- https://redmine.pfsense.org/issues/9610
- https://www.seebug.org/vuldb/ssvid-98024
Get alerted when CVE-2019-16915 or the next vulnerability affects your stack