What’s Vulnerable › Vulnerabilities
CVE-2019-16932
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 39.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-30 · updated 2026-06-17
- Weakness: CWE-918
Description
A blind SSRF vulnerability exists in the Visualizer plugin before 3.3.1 for WordPress via wp-json/visualizer/v1/upload-data.
Affected products
- themeisle Visualizer: Tables and Charts Manager for WordPress: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: themeisle Visualizer: Tables and Charts Manager for WordPress 3.3.1. Check the vendor advisory for mitigations.
References
- https://nathandavison.com/blog/wordpress-visualizer-plugin-xss-and-ssrf
- https://wordpress.org/plugins/visualizer/#developers
- https://wpvulndb.com/vulnerabilities/9892
- https://nathandavison.com/blog/wordpress-visualizer-plugin-xss-and-ssrf
- https://wordpress.org/plugins/visualizer/#developers
- https://wpvulndb.com/vulnerabilities/9892
Get alerted when CVE-2019-16932 or the next vulnerability affects your stack