What’s Vulnerable › Vulnerabilities
CVE-2019-16935
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-28 · updated 2026-10-07
- Weakness: CWE-79
Description
The documentation XML-RPC server in Python through 2.7.16, 3.x through 3.6.9, and 3.7.x through 3.7.4 has XSS via the server_title field. This occurs in Lib/DocXMLRPCServer.py in Python 2.x, and in Lib/xmlrpc/server.py in Python 3.x. If set_server_title is called with untrusted input, arbitrary JavaScript can be delivered to clients that visit the http URL for this server.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 9.0
- Python: from 2.7.0 before 2.7.17; from 3.0.0 before 3.5.8; from 3.6.0 before 3.6.10; from 3.7.0 before 3.7.5 — fixed in 2.7.17, 3.5.8, 3.6.10, 3.7.5
How to fix
Upgrade to a fixed version: Python 2.7.17, 3.5.8, 3.6.10, 3.7.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00062.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00063.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00040.html
- https://bugs.python.org/issue38243
- https://github.com/python/cpython/blob/35c0809158be7feae4c4f877a08b93baea2d8291/Lib/xmlrpc/server.py#L897
- https://github.com/python/cpython/blob/e007860b8b3609ce0bc62b1780efaa06241520bd/Lib/DocXMLRPCServer.py#L213
- https://github.com/python/cpython/pull/16373
- https://lists.debian.org/debian-lts-announce/2020/07/msg00011.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4X3HW5JRZ7GCPSR7UHJOLD7AWLTQCDVR/
Get alerted when CVE-2019-16935 or the next vulnerability affects your stack