What’s Vulnerable › Vulnerabilities
CVE-2019-17002
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-08 · updated 2026-06-17
Description
If upgrade-insecure-requests was specified in the Content Security Policy, and a link was dragged and dropped from that page, the link was not upgraded to https. This vulnerability affects Firefox < 70.
Affected products
- Mozilla Firefox: before 70.0 — fixed in 70.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 70.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1561056
- https://www.mozilla.org/security/advisories/mfsa2019-34/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1561056
- https://www.mozilla.org/security/advisories/mfsa2019-34/
Get alerted when CVE-2019-17002 or the next vulnerability affects your stack