What’s Vulnerable › Vulnerabilities
CVE-2019-17005
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-08 · updated 2026-06-17
- Weakness: CWE-787
Description
The plain text serializer used a fixed-size array for the number of <ol> elements it could process; however it was possible to overflow the static-sized array leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Mozilla Firefox: before 71.0 — fixed in 71.0
- Mozilla Firefox ESR: before 68.3 — fixed in 68.3
- Mozilla Thunderbird: before 68.3 — fixed in 68.3
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Mozilla Firefox 71.0; Mozilla Firefox ESR 68.3; Mozilla Thunderbird 68.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00001.html
- https://access.redhat.com/errata/RHSA-2020:0292
- https://access.redhat.com/errata/RHSA-2020:0295
- https://bugzilla.mozilla.org/show_bug.cgi?id=1584170
- https://security.gentoo.org/glsa/202003-02
- https://security.gentoo.org/glsa/202003-10
- https://usn.ubuntu.com/4241-1/
- https://usn.ubuntu.com/4335-1/
- https://www.mozilla.org/security/advisories/mfsa2019-36/
- https://www.mozilla.org/security/advisories/mfsa2019-37/
- https://www.mozilla.org/security/advisories/mfsa2019-38/
Get alerted when CVE-2019-17005 or the next vulnerability affects your stack