What’s Vulnerable › Vulnerabilities
CVE-2019-1701: Cisco Adaptive Security Appliance and Firepower Threat Defense Software WebVPN Cross-Site Scripting Vulnerabilities
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-03 · updated 2026-08-11
- Weakness: CWE-79
Description
Multiple vulnerabilities in the WebVPN service of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the WebVPN portal of an affected device. The vulnerabilities exist because the software insufficiently validates user-supplied input on an affected device. An attacker could exploit these vulnerabilities by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive browser-based information. An attacker would need administrator privileges on the device to exploit these vulnerabilities.
Affected products
- Cisco ASA Software: before 9.4.4.34; from 9.5 before 9.6.4.25; from 9.7 before 9.8.4; from 9.9 before 9.9.2.50; from 9.10 before 9.10.1.17 — fixed in 9.10.1.17, 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50
- Cisco Firepower Threat Defense Software: from 6.2.1 before 6.2.3.12; from 6.3.0 before 6.3.0.3 — fixed in 6.2.3.12, 6.3.0.3
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.10.1.17, 9.4.4.34, 9.6.4.25, 9.8.4; Cisco Firepower Threat Defense Software 6.2.3.12, 6.3.0.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108152
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-asa-ftd-xss
- http://www.securityfocus.com/bid/108152
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-asa-ftd-xss
Get alerted when CVE-2019-1701 or the next vulnerability affects your stack