What’s Vulnerable › Vulnerabilities
CVE-2019-17020
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-08 · updated 2026-06-17
- Weakness: CWE-611
Description
If an XML file is served with a Content Security Policy and the XML file includes an XSL stylesheet, the Content Security Policy will not be applied to the contents of the XSL stylesheet. If the XSL sheet e.g. includes JavaScript, it would bypass any of the restrictions of the Content Security Policy applied to the XML document. This vulnerability affects Firefox < 72.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Mozilla Firefox: before 72.0 — fixed in 72.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 72.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1597645
- https://usn.ubuntu.com/4234-1/
- https://www.mozilla.org/security/advisories/mfsa2020-01/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1597645
- https://usn.ubuntu.com/4234-1/
- https://www.mozilla.org/security/advisories/mfsa2020-01/
Get alerted when CVE-2019-17020 or the next vulnerability affects your stack